vmware tools required on guest?

Feb 10, 2011 at 11:10 PM

It seems like vmware tools is required on the guest OS or RemoteInstall just sits at "Waiting on <os>...".  I assume that vmware tools lets VIX communicate to the guest about the state of the guest OS.  If this is accurate dblock, I'll send you another patch on the Getting Started doc page. 

Developer
Feb 10, 2011 at 11:30 PM
Edited Feb 10, 2011 at 11:32 PM

I am not sure if vmware tools is a requirement, but I have not tried it otherwise myself.

For example, I think a copymethod set to "network" will not require vmware tools to be installed on the guest OS.

But this may limit you on what kind of tests are run.

If a psexec type of technology is used, which I don't believe it currently is, this will allow you to remotely execute commands on the guest os without the vmware api for example.

Feb 11, 2011 at 1:59 AM

After more research I'm almost 100% sure that it is required.  Once we installed it, we got past the "Waiting on VM" message which had previous got us stuck.  If we watched it (without VMware tools) the VM started and just sat there while RemoteInstall waited for it.  Therefore I'm becoming convinced that without Vmware tools, the VIX API can't tell whether the VM is booted or not.

Developer
Feb 11, 2011 at 2:28 AM

> without Vmware tools, the VIX API can't tell whether the VM is booted or not.

That is correct.

http://www.vmware.com/support/developer/vix-api/vix110_reference/

"The VIX API relies on a current matching version of VMware Tools to perform many operations."

The real question is what vix api operations does your configuration use and can they be (currently) circumvented (ex. using the "network" copymethod instead of the default "vmware"). ;)

Feb 11, 2011 at 2:45 AM
icnopop:
I think the answer is no, this cannot be circumvented, since RemoteInstall will never get past this (below) without the tools.  
Powering on 'Remote:Win7x86' 
Waiting for 'Remote:Win7x86'


The next step would be logging in and then copying the file.   I have no issue with the requirement, I just think we should add it to the Getting Started page, so I'm going to make a patch, unless dblock needs to weigh-in first.

Developer
Feb 12, 2011 at 3:22 AM

For example, if you just use the current snapshot, RemoteInstaller.exe does not need to power on the vm, and so maybe the vmware tools are not required.

But I did notice that if a power on is performed, that RemoteInstaller.exe will always wait for tools in guest.

Feb 12, 2011 at 3:25 AM

That mirrors exactly what we saw.  If we used the current snapshot it worked, if we restored a named snapshot, it did not.